re = /http(s)?:\/\/(.*?[^\/])*?\S+/m
str = 'Пока использую только функции разблокировки экрана, быстрого запуска приложений, частных записок, задач профиля и приложений, также будильник. http://site.ru/gertolgd
Работает хорошо при прикосновении определенной точкой кольца к задней стенке телефона. http://site.ru/geaafasf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end