using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?<Date>.*?\s)(?<Time>.*?), INFO(?<INFO>.*?),(?<Level>.*?), EID: (?<EID>.*?), UID:(?<UID>.*?), Message:(?<Message>.*?)""";
string input = @"string line = ""2019-05-07 11:50:28, INFO Ayush Singhania, Level 1, EID: 1001, UID: ayush.power, Message: Create a mWorkderCIS Job""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}