package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"(?<Date>.*?\s)(?<Time>.*?), INFO(?<INFO>.*?),(?<Level>.*?), EID: (?<EID>.*?), UID:(?<UID>.*?), Message:(?<Message>.*?)"`)
var str = `string line = "2019-05-07 11:50:28, INFO Ayush Singhania, Level 1, EID: 1001, UID: ayush.power, Message: Create a mWorkderCIS Job"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}