import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\+?011-?)?599(416|717|318)[0-9]{4}\n"
+ "|\n"
+ "08[58]-?[0-9]{7}(,[1-9][0-9]{1,8})?\n"
+ "|\n"
+ "(\\+31|0|0031)[1-9][0-9]{2}-?[1-9][0-9]{5}(,[1-9][0-9]{1,8})?\n"
+ "|\n"
+ "(\\+31|0|0031)[1-9][0-9]-?[1-9][0-9]{6}(,[1-9][0-9]{1,8})?\n"
+ "|\n"
+ "14-?0[1-9][0-9]{1,2}\n"
+ "|\n"
+ "(\\+31|0|0031)6-?[1-9][0-9]{7}\n"
+ "|\n"
+ "\\+(1\\d{4,14}|2[078]\\d{3,13}|3[0-469]\\d{3,13}|4[013-9]\\d{3,13}|5[1-9]\\d{3,13}|6[0-6]\\d{3,13}|7\\d{4,14}|8[1-469]\\d{3,13}|9[0-58]\\d{3,13}|[2-9]\\d{4,14})";
final String string = "03151364512";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}