$re = '/(\+?011-?)?599(416|717|318)[0-9]{4}
|
08[58]-?[0-9]{7}(,[1-9][0-9]{1,8})?
|
(\+31|0|0031)[1-9][0-9]{2}-?[1-9][0-9]{5}(,[1-9][0-9]{1,8})?
|
(\+31|0|0031)[1-9][0-9]-?[1-9][0-9]{6}(,[1-9][0-9]{1,8})?
|
14-?0[1-9][0-9]{1,2}
|
(\+31|0|0031)6-?[1-9][0-9]{7}
|
\+(1\d{4,14}|2[078]\d{3,13}|3[0-469]\d{3,13}|4[013-9]\d{3,13}|5[1-9]\d{3,13}|6[0-6]\d{3,13}|7\d{4,14}|8[1-469]\d{3,13}|9[0-58]\d{3,13}|[2-9]\d{4,14})/mx';
$str = '03151364512';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);