#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)counter\((?:[^)(]+|\((?:[^)(]+|\([^)(]*\))*\))*\)"
Local $sString = "counter()" & @CRLF & _
"counter(123, "this string has (nested) parentheses")" & @CRLF & _
"counter(123, "this string has mis-matched)( parentheses")" & @CRLF & _
"" & @CRLF & _
"counter(item)" " attr(data) "" counter(item1,decimal) url('test.jpeg') "hi" attr(xyz);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")