const regex = /counter\((?:[^)(]+|\((?:[^)(]+|\([^)(]*\))*\))*\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('counter\\((?:[^)(]+|\\((?:[^)(]+|\\([^)(]*\\))*\\))*\\)', 'gm')
const str = `counter()
counter(123, "this string has (nested) parentheses")
counter(123, "this string has mis-matched)( parentheses")
counter(item)" " attr(data) "" counter(item1,decimal) url('test.jpeg') "hi" attr(xyz);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}