import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "counter\\((?:[^)(]+|\\((?:[^)(]+|\\([^)(]*\\))*\\))*\\)";
final String string = "counter()\n"
+ "counter(123, \"this string has (nested) parentheses\")\n"
+ "counter(123, \"this string has mis-matched)( parentheses\")\n\n"
+ "counter(item)\" \" attr(data) \"\" counter(item1,decimal) url('test.jpeg') \"hi\" attr(xyz);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}