#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9äöüß.!#$%&’*+/=?^_`{|}~-]+@[a-zA-Z0-9-äöüß]+(?:\.[a-zA-Z0-9-äöüß]+)*$"
Local $sString = "a@b" & @CRLF & _
"max.mustermann@bahn.de" & @CRLF & _
"team-ümlaut@test.com" & @CRLF & _
"stußmail@ümlaut.tülüdü" & @CRLF & _
"_@test.de" & @CRLF & _
"@.de" & @CRLF & _
".@." & @CRLF & _
"ohneATgehtnix.de" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")