package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9äöüß.!#$%&’*+/=?^_`{|}~-]+@[a-zA-Z0-9-äöüß]+(?:\.[a-zA-Z0-9-äöüß]+)*$`)
var str = `a@b
max.mustermann@bahn.de
team-ümlaut@test.com
stußmail@ümlaut.tülüdü
_@test.de
@.de
.@.
ohneATgehtnix.de
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}