import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:Mr|Ms|Mrs))\\h\\h(.*?(?=\\s{2}))\\h\\h(.*?(?=\\s{2}))";
final String string = "johndoe@gmail.com\n\n"
+ "Passengers\n\n"
+ "Title First name Last name\n"
+ "Mr John Martin Doe Santos\n"
+ "Ms Estelle Lana Johnson Santos\n\n"
+ "Itinerary\n\n"
+ "From\n"
+ "Lagos (LOS), NG \n"
+ "To\n"
+ "London (LHR), GB\n"
+ " Date\n"
+ "27 - Jan - 2022\n\n\n\n"
+ "From\n"
+ "London (LHR), GB \n"
+ "To\n"
+ "Lagos (LOS), NG Date\n"
+ "21 - Feb - 2022";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}