const regex = /((?:Mr|Ms|Mrs))\h\h(.*?(?=\s{2}))\h\h(.*?(?=\s{2}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:Mr|Ms|Mrs))\\h\\h(.*?(?=\\s{2}))\\h\\h(.*?(?=\\s{2}))', 'gm')
const str = `johndoe@gmail.com
Passengers
Title First name Last name
Mr John Martin Doe Santos
Ms Estelle Lana Johnson Santos
Itinerary
From
Lagos (LOS), NG
To
London (LHR), GB
Date
27 - Jan - 2022
From
London (LHR), GB
To
Lagos (LOS), NG Date
21 - Feb - 2022`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}