import re
regex = re.compile(r"((?:Mr|Ms|Mrs))\h\h(.*?(?=\s{2}))\h\h(.*?(?=\s{2}))", flags=re.MULTILINE)
test_str = ("johndoe@gmail.com\n\n"
"Passengers\n\n"
"Title First name Last name\n"
"Mr John Martin Doe Santos\n"
"Ms Estelle Lana Johnson Santos\n\n"
"Itinerary\n\n"
"From\n"
"Lagos (LOS), NG \n"
"To\n"
"London (LHR), GB\n"
" Date\n"
"27 - Jan - 2022\n\n\n\n"
"From\n"
"London (LHR), GB \n"
"To\n"
"Lagos (LOS), NG Date\n"
"21 - Feb - 2022")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")