#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![^\n]*\.$)(?:https?:\/\/)?(?:(?:[2][1-4]\d|25[1-5]|1\d{2}|[1-9]\d|[1-9])(?:\.(?:[2][1-4]\d|25[1-5]|1\d{2}|[1-9]\d|[0-9])){3}(?::\d{4})?|[a-z\-]+(?:\.[a-z\-]+){2,})$"
Local $sString = "http://" & @CRLF & _
"http://test." & @CRLF & _
"192.56." & @CRLF & _
"192.65" & @CRLF & _
"test.xyz" & @CRLF & _
"" & @CRLF & _
"http://abcd.nju.in" & @CRLF & _
"flower.insu-rge.ui" & @CRLF & _
"192.89.32.4:8989" & @CRLF & _
"https://170.45.6.7" & @CRLF & _
"172.36.23.5" & @CRLF & _
"255.255.255.255" & @CRLF & _
"10.1.0.1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")