import re
regex = re.compile(r"^(?![^\n]*\.$)(?:https?:\/\/)?(?:(?:[2][1-4]\d|25[1-5]|1\d{2}|[1-9]\d|[1-9])(?:\.(?:[2][1-4]\d|25[1-5]|1\d{2}|[1-9]\d|[0-9])){3}(?::\d{4})?|[a-z\-]+(?:\.[a-z\-]+){2,})$", flags=re.MULTILINE)
test_str = ("http://\n"
"http://test.\n"
"192.56.\n"
"192.65\n"
"test.xyz\n\n"
"http://abcd.nju.in\n"
"flower.insu-rge.ui\n"
"192.89.32.4:8989\n"
"https://170.45.6.7\n"
"172.36.23.5\n"
"255.255.255.255\n"
"10.1.0.1\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")