$re = '/^(?![^\n]*\.$)(?:https?:\/\/)?(?:(?:[2][1-4]\d|25[1-5]|1\d{2}|[1-9]\d|[1-9])(?:\.(?:[2][1-4]\d|25[1-5]|1\d{2}|[1-9]\d|[0-9])){3}(?::\d{4})?|[a-z\-]+(?:\.[a-z\-]+){2,})$/m';
$str = 'http://
http://test.
192.56.
192.65
test.xyz
http://abcd.nju.in
flower.insu-rge.ui
192.89.32.4:8989
https://170.45.6.7
172.36.23.5
255.255.255.255
10.1.0.1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);