import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td>(?=.*\\,\\s\\d{4}\\s\\d{2}\\:\\d{2}\\s[A-Z]{2}\\s[A-Z]{3})(.*)(?=\\<\\/td)";
final String string = "<td>Aug 17, 2017 02:00 PM EDT</td>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}