const regex = /<td>(?=.*\,\s\d{4}\s\d{2}\:\d{2}\s[A-Z]{2}\s[A-Z]{3})(.*)(?=\<\/td)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<td>(?=.*\\,\\s\\d{4}\\s\\d{2}\\:\\d{2}\\s[A-Z]{2}\\s[A-Z]{3})(.*)(?=\\<\\\/td)', 'g')
const str = `<td>Aug 17, 2017 02:00 PM EDT</td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}