re = /<td>(?=.*\,\s\d{4}\s\d{2}\:\d{2}\s[A-Z]{2}\s[A-Z]{3})(.*)(?=\<\/td)/
str = '<td>Aug 17, 2017 02:00 PM EDT</td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end