using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\<meta([\s]*(name=""viewport""){1})[\w\d\s\.\-,=]*(content=""){1}[\w\d\s\.\-,=]*(viewport-fit=cover){1}[\w\d\s\.\-,=""]+\/\>)";
string input = @"<!DOCTYPE html>
<html lang=""en"">
<head>
<meta charset=""utf-8"" />
<title>Ionic App</title>
<base href=""/"" />
<!-- viewport-fit on multiline meta -->
<meta name=""viewport""
content=""viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no""
/>
<meta
name=""viewport"" content=""viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no""
/>
<meta
name=""viewport""
content=""viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no""
/>
<!-- viewport-fit on singleline content at the start -->
<meta name=""viewport"" content=""viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no"" />
<!-- viewport-fit on singleline content at the end -->
<meta name=""viewport"" content=""width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no, viewport-fit=cover"" />
<meta name=""format-detection"" content=""telephone=no"" />
<meta name=""msapplication-tap-highlight"" content=""no"" />
<link rel=""icon"" href=""assets/icon/favicon.ico"" />
<!-- add to homescreen for ios -->
<meta name=""apple-mobile-web-app-capable"" content=""yes"" />
<meta name=""apple-mobile-web-app-status-bar-style"" content=""black"" />
</head>
<body>
<app-root></app-root>
</body>
</html>
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}