import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\<meta([\\s]*(name=\"viewport\"){1})[\\w\\d\\s\\.\\-,=]*(content=\"){1}[\\w\\d\\s\\.\\-,=]*(viewport-fit=cover){1}[\\w\\d\\s\\.\\-,=\"]+\\/\\>)";
final String string = "<!DOCTYPE html>\n"
+ "<html lang=\"en\">\n"
+ " <head>\n"
+ " <meta charset=\"utf-8\" />\n"
+ " <title>Ionic App</title>\n\n"
+ " <base href=\"/\" />\n\n"
+ " <!-- viewport-fit on multiline meta -->\n"
+ " <meta name=\"viewport\"\n"
+ " content=\"viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no\"\n"
+ " />\n"
+ " <meta\n"
+ " name=\"viewport\" content=\"viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no\"\n"
+ " />\n"
+ " <meta\n"
+ " name=\"viewport\"\n"
+ " content=\"viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no\"\n"
+ " />\n\n"
+ " <!-- viewport-fit on singleline content at the start -->\n"
+ " <meta name=\"viewport\" content=\"viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no\" />\n\n"
+ " <!-- viewport-fit on singleline content at the end -->\n"
+ " <meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no, viewport-fit=cover\" />\n\n"
+ " <meta name=\"format-detection\" content=\"telephone=no\" />\n"
+ " <meta name=\"msapplication-tap-highlight\" content=\"no\" />\n\n"
+ " <link rel=\"icon\" href=\"assets/icon/favicon.ico\" />\n\n"
+ " <!-- add to homescreen for ios -->\n"
+ " <meta name=\"apple-mobile-web-app-capable\" content=\"yes\" />\n"
+ " <meta name=\"apple-mobile-web-app-status-bar-style\" content=\"black\" />\n"
+ " </head>\n"
+ " <body>\n"
+ " <app-root></app-root>\n"
+ " </body>\n"
+ "</html>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}