# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\<meta([\s]*(name=\"viewport\"){1})[\w\d\s\.\-,=]*(content=\"){1}[\w\d\s\.\-,=]*(viewport-fit=cover){1}[\w\d\s\.\-,=\"]+\/\>)"
test_str = ("<!DOCTYPE html>\n"
"<html lang=\"en\">\n"
" <head>\n"
" <meta charset=\"utf-8\" />\n"
" <title>Ionic App</title>\n\n"
" <base href=\"/\" />\n\n"
" <!-- viewport-fit on multiline meta -->\n"
" <meta name=\"viewport\"\n"
" content=\"viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no\"\n"
" />\n"
" <meta\n"
" name=\"viewport\" content=\"viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no\"\n"
" />\n"
" <meta\n"
" name=\"viewport\"\n"
" content=\"viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no\"\n"
" />\n\n"
" <!-- viewport-fit on singleline content at the start -->\n"
" <meta name=\"viewport\" content=\"viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no\" />\n\n"
" <!-- viewport-fit on singleline content at the end -->\n"
" <meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no, viewport-fit=cover\" />\n\n"
" <meta name=\"format-detection\" content=\"telephone=no\" />\n"
" <meta name=\"msapplication-tap-highlight\" content=\"no\" />\n\n"
" <link rel=\"icon\" href=\"assets/icon/favicon.ico\" />\n\n"
" <!-- add to homescreen for ios -->\n"
" <meta name=\"apple-mobile-web-app-capable\" content=\"yes\" />\n"
" <meta name=\"apple-mobile-web-app-status-bar-style\" content=\"black\" />\n"
" </head>\n"
" <body>\n"
" <app-root></app-root>\n"
" </body>\n"
"</html>\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.