import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*\\/)[^?]*(?:(\\?[^&]*).*)?";
final String string = "1. http://www.example.com/myplan/mp/public/pl_be?Id=543543×tamp=06280435435\n\n"
+ "2. http://www.example.com/course/df/public/pl_de?Id=454354×tamp=0628031746\n\n"
+ "3. http://www.example.com/book/rg/public/pl_fo?Id=4445577×tamp=0628031734\n\n"
+ "4. http://www.example.com/trip/tr/public/pl_ds?Id=454354×tamp=06280314546\n\n"
+ "5. http://www.example.com/trip/tr/public/pl_ds";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}