const regex = /(.*\/)[^?]*(?:(\?[^&]*).*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*\\\/)[^?]*(?:(\\?[^&]*).*)?', 'gm')
const str = `1. http://www.example.com/myplan/mp/public/pl_be?Id=543543×tamp=06280435435
2. http://www.example.com/course/df/public/pl_de?Id=454354×tamp=0628031746
3. http://www.example.com/book/rg/public/pl_fo?Id=4445577×tamp=0628031734
4. http://www.example.com/trip/tr/public/pl_ds?Id=454354×tamp=06280314546
5. http://www.example.com/trip/tr/public/pl_ds`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);