# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*\/)[^?]*(?:(\?[^&]*).*)?"
test_str = ("1. http://www.example.com/myplan/mp/public/pl_be?Id=543543×tamp=06280435435\n\n"
"2. http://www.example.com/course/df/public/pl_de?Id=454354×tamp=0628031746\n\n"
"3. http://www.example.com/book/rg/public/pl_fo?Id=4445577×tamp=0628031734\n\n"
"4. http://www.example.com/trip/tr/public/pl_ds?Id=454354×tamp=06280314546\n\n"
"5. http://www.example.com/trip/tr/public/pl_ds")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.