using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(\()\s*(?'MeineZahl'[\d]{1,3})\s*(?=\)))";
string input = @"UDTKCVSP ( 31 )
UDTKCVSP (31)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}