re = /(?=(\()\s*(?'MeineZahl'[\d]{1,3})\s*(?=\)))/m
str = 'UDTKCVSP ( 31 )
UDTKCVSP (31)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end