import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!name\\()([\"'])[^\\)]+?(?<!\\\\)\\1";
final String string = "\n"
+ "dlfksj \"hello1\" dsffsf \"hello2\\\"hi\" name(\"Tod\").name('tod') 'hello3' tye(\"hh\")\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}