re = /(?<!name\()(["'])[^\)]+?(?<!\\)\1/m
str = '
dlfksj "hello1" dsffsf "hello2\\"hi" name("Tod").name(\'tod\') \'hello3\' tye("hh")
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end