$re = '/(?<!name\()(["\'])[^\)]+?(?<!\\\\)\1/m';
$str = '
dlfksj "hello1" dsffsf "hello2\\"hi" name("Tod").name(\'tod\') \'hello3\' tye("hh")
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);