package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^.\n]*\.[^.\n]*$`)
var str = `ac.def=1
and
xy.z.kt='10'
and
k.t=1
or
xy.z.kt.lm='10'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}