import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^.\\n]*\\.[^.\\n]*$";
final String string = "ac.def=1\n"
+ "and\n"
+ "xy.z.kt='10'\n"
+ "and\n"
+ "k.t=1\n"
+ "or\n"
+ "xy.z.kt.lm='10'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}