re = /^[^.\n]*\.[^.\n]*$/m
str = 'ac.def=1
and
xy.z.kt=\'10\'
and
k.t=1
or
xy.z.kt.lm=\'10\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end