package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w ]+:[^\S\r\n]?\${[A-Z_]+}(?:\r?\n[\w ]+:[^\S\r\n]?\${[A-Z_]+})*$`)
var str = `Text description: ${VARIABLE_NAME}
Text description: ${VARIABLE_NAME}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}