import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w ]+:[^\\S\\r\\n]?\\$\\{[A-Z_]+\\}(?:\\r?\\n[\\w ]+:[^\\S\\r\\n]?\\$\\{[A-Z_]+\\})*$";
final String string = "Text description: ${VARIABLE_NAME}\n"
+ "Text description: ${VARIABLE_NAME}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}