#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bstyle(?:=(["'])[^"]*\1)?"
Local $sString = "style="font-family:"Open Sans", Arial, sans-serif;background-color:rgb(255, 255, 255);display:inline !important;"" & @CRLF & _
"style=""" & @CRLF & _
"style="something" " & @CRLF & _
"style" & @CRLF & _
"" & @CRLF & _
"style='font-family:"Open Sans", Arial, sans-serif;background-color:rgb(255, 255, 255);display:inline !important;'" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")