const regex = /\bstyle(?:=(["'])[^"]*\1)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bstyle(?:=(["\'])[^"]*\\1)?', 'gm')
const str = `style="font-family:"Open Sans", Arial, sans-serif;background-color:rgb(255, 255, 255);display:inline !important;"
style=""
style="something"
style
style='font-family:"Open Sans", Arial, sans-serif;background-color:rgb(255, 255, 255);display:inline !important;'
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}