package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<pun1>\d{3})\s+(?P<pun2>\d{6})(\s+(?P<pun3>[01oO])(\s+(?P<pun4>\d{4}))?)?\s.*\s(?P<amt>\d+\.\d\d)\s`)
var str = `105297 003 002394 o 0000 20891 0.00 1
105297 003 002394 o 0000 20891 0.00 1
105297 003 002394 o 0000 20891 0.00 1
105297 003 002394 o 0000 20891 0.00 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}