$re = '/(?P<pun1>\d{3})\s+(?P<pun2>\d{6})(\s+(?P<pun3>[01oO])(\s+(?P<pun4>\d{4}))?)?\s.*\s(?P<amt>\d+\.\d\d)\s/m';
$str = '105297 003 002394 o 0000 20891 0.00 1
105297 003 002394 o 0000 20891 0.00 1
105297 003 002394 o 0000 20891 0.00 1
105297 003 002394 o 0000 20891 0.00 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);