#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\b(?![A-Za-z]{7,})(?![\d]{7,})(?=[a-zA-Z\d]{2})[A-Za-z\d]{8}\b)"
Local $sString = "yi12345678" & @CRLF & _
"i1234567" & @CRLF & _
"i12345u8" & @CRLF & _
"12345678 " & @CRLF & _
"papave23 ciao il mio pin papaver1 รจ reeredji332ji con vaff8loe 1234567o 123t123t papavero 9o 123t123y" & @CRLF & _
"dssdsdsffvdffvdfv " & @CRLF & _
"389223897894237234894722348972348924" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")