re = /(\b(?![A-Za-z]{7,})(?![\d]{7,})(?=[a-zA-Z\d]{2})[A-Za-z\d]{8}\b)/
str = 'yi12345678
i1234567
i12345u8
12345678
papave23 ciao il mio pin papaver1 รจ reeredji332ji con vaff8loe 1234567o 123t123t papavero 9o 123t123y
dssdsdsffvdffvdfv
389223897894237234894722348972348924
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end