const regex = /\b\d\d:\d\d\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d\\d:\\d\\d\\b', 'gm')
const str = `Hello, today its 31/05/18 and the time is 08:13, time for breakfast`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}