import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\.\\s).*?tupak.*?(?=\\.\\s)";
final String string = "Joskus pelkkä tekstinlouhinta ei yksinään riitä, mutta se voi silti nopeuttaa tutkimuksen tekemistä äärimmäisen paljon. Eräs esimerkki usein tutkimuksellisesti merkittävästä, mutta työläästi määriteltävästä kliinisestä muuttujasta on potilaan tupakointistatus. Regex-komennolla ”(?<=\\.\\s).*?tupak.*?(?=\\.\\s)” saa nopeasti louhittua tekstin seasta kaikki ne lauseet, joissa puhutaan tupakoinnista (DEMO ). Vaikka lauseiden varsinainen sisältö pitäisikin vielä tarkistaa käsin, on luettavan tekstin määrä jo tällä haulla tippunut murto-osaan alkuperäisestä.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}