$re = '/(?<=\.\s).*?tupak.*?(?=\.\s)/';
$str = 'Joskus pelkkä tekstinlouhinta ei yksinään riitä, mutta se voi silti nopeuttaa tutkimuksen tekemistä äärimmäisen paljon. Eräs esimerkki usein tutkimuksellisesti merkittävästä, mutta työläästi määriteltävästä kliinisestä muuttujasta on potilaan tupakointistatus. Regex-komennolla ”(?<=\\.\\s).*?tupak.*?(?=\\.\\s)” saa nopeasti louhittua tekstin seasta kaikki ne lauseet, joissa puhutaan tupakoinnista (DEMO ). Vaikka lauseiden varsinainen sisältö pitäisikin vielä tarkistaa käsin, on luettavan tekstin määrä jo tällä haulla tippunut murto-osaan alkuperäisestä.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);