import re
regex = re.compile(r"(?<=\.\s).*?tupak.*?(?=\.\s)")
test_str = "Joskus pelkkä tekstinlouhinta ei yksinään riitä, mutta se voi silti nopeuttaa tutkimuksen tekemistä äärimmäisen paljon. Eräs esimerkki usein tutkimuksellisesti merkittävästä, mutta työläästi määriteltävästä kliinisestä muuttujasta on potilaan tupakointistatus. Regex-komennolla ”(?<=\\.\\s).*?tupak.*?(?=\\.\\s)” saa nopeasti louhittua tekstin seasta kaikki ne lauseet, joissa puhutaan tupakoinnista (DEMO ). Vaikka lauseiden varsinainen sisältö pitäisikin vielä tarkistaa käsin, on luettavan tekstin määrä jo tällä haulla tippunut murto-osaan alkuperäisestä."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")