package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) +$`)
var str = ` first line... abc
second is here... def
//<-- blank space here
fourth line... hi there
sith is here.... `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}