$re = '/ +$/m';
$str = ' first line... abc
second is here... def
//<-- blank space here
fourth line... hi there
sith is here.... ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);