using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( # outer group
\b(floor|roof) # floor or roof
(?:\W+\w+){1,6}\s* # any six ""words""
)
\btiles?\b # tile or tiles";
string input = @"After the storm the roof was damaged and some of the tiles are missing
I dropped the saw and it fell on the floor and damaged some of the tiles
the roof was leaking and when I checked I saw that some of the tiles were cracked";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}