import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( # outer group\n"
+ " \\b(floor|roof) # floor or roof\n"
+ " (?:\\W+\\w+){1,6}\\s* # any six \"words\"\n"
+ ")\n"
+ "\\btiles?\\b # tile or tiles";
final String string = "After the storm the roof was damaged and some of the tiles are missing\n"
+ "I dropped the saw and it fell on the floor and damaged some of the tiles\n"
+ "the roof was leaking and when I checked I saw that some of the tiles were cracked";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}