const regex = new RegExp('( # outer group
\\b(floor|roof) # floor or roof
(?:\\W+\\w+){1,6}\\s* # any six "words"
)
\\btiles?\\b # tile or tiles', 'g')
const str = `After the storm the roof was damaged and some of the tiles are missing
I dropped the saw and it fell on the floor and damaged some of the tiles
the roof was leaking and when I checked I saw that some of the tiles were cracked`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}